Hauptmenü öffnen

Freifunk Potsdam | Wiki β

Ubiquiti2 Erfahrungsbericht

Inhaltsverzeichnis

Ubiquiti NanoStation2 Erfahrungsbericht

Dies ist ein Erfahrungsbericht/Anleitung wie ich meinen Freifunk-Knoten zum laufen bekommen habe. Die Beschreibung ist vom Nov 2010, und muss gegebenenfalls vom Leser entsprechend den aktuellen Bedingungen und Anwendungsfällen angepasst werden.

Das Vorgehen ist wie immer:

  1. IP im Wiki Eintragen IP-Adressen
  2. Firmware Flashen
  3. Konfiguration
  4. Inbetriebnahme

Anwendungsfall

  • Ca. 300m Distanz und freie Sicht zum nächsten Knoten.
  • Kein ADSL, Knoten soll auf den LAN Schnittstelle IPs ausliefern, und Verkehr

ins Freifunk-Netz liefern.

  • Haus mit beschichteten Scheiben, Antenne muss draussen angebracht werden.

Gerät

Es handelt sich um eine Ubiquiti NanoStation2, dich ich kostengünstig (79,- €) inkl. 10m ultraflaches Kabel (Cat-6 10,- €) bei Frank Hofman in Berlin gekauft habeg. Vorteil von diesem Gerät war für mich der Power-Over-Ethernet (POE) Anschluss, da bei uns Zuhause die beschichteten Scheiben verhindern das die Antenne innen angebracht werden kann. Mit dem flachen Ethernet-Kabel ist die Montage draussen am Balkon sehr komfortabel, da das Kabel einfach zwischen Fenster und Rahmen eingeklemmt wird. In wie weit das Kabel häufiges öffnen und schliessen der Tür überlebt, wird sich zeigen. Im übrigen ist noch zu, sagen daß das Einspeisegerät für POE mitgeliefert wird.

Firmware

Ich habe die Backfire-Firmware verwendet:

 OpenWrt Backfire 10.03 build date: 2010-10-26_01-45

Ein fertiges Image fand ich unter: http://kifuse02.pberg.freifunk.net/backfire/10.03-timestamp/

Das Image heisst:

 openwrt-atheros-ubnt2-squashfs.bin

Flashen

Von Hause aus hat die NanoStation2 die IP 192.168.1.20, Username und Passwort stehen auf der Verpackung. Sie liefert per Default keine IP Adressen aus (dhcpd is aus), also muss man sich selber eine zuweisen, z.B. 192.168.1.21. Flashen geht einfach über das Webinterface der Ubiquiti-Firmware. Diese beschwert sich das es sich nicht um eine original Firmware handelt, und das man sich mit der Prozedur zum Wiederherstellen der original Firmware vertraut machen solle. Diese Warnung ist getrost zu ignorieren.

Konfiguration

Nach dem Neustart liefert die Backfire-Firmware IPs aus, und ist unter 192.168.1.1 zu erreichen, am besten als erstes mit dem Username 'root' und dem Passwort 'admin' einloggen, und das Passwort ändern.

Die Freifunk-Konfiguration kann vollständig über Das Webinterface gemacht werden. Unter 'Freifunk -> Freifunkassistent' können fast alle notwendigen Einstellungen gemacht werden.

Freifunk -> Freifunkassistent

Freifunk Community : Freifunk Potsdam (10.22.0.0/16)

Knoten Name  : $KNOTEN_NAME

Standort  : $EUER_STANDORT

Email  : $EURE_EMAIL

Netzwerk einrichten : Haken setzen

Drahtloses Netzwerk "WIFI0" : Haken setzen

WIFI0 Freifunk Kanal einrichten : 13

WIFI0 Mesh IP Adresse einrichten : $KNOTEN_IP

WIFI0 DHCP anbieten : Haken setzen

WIFI0 Mesh DHCP anbieten : $GEEIGNETES_NETZ

Virtueller Drahtloser Zugangspunkt : Haken setzen

Die Knoten-IP muss man sich wie schon erwähnt selber zuteilen, siehe: IP-Adressen. Der Knoten-Name setzt sich aus dem vorletzten und dem letzten Oktett eurer Knoten-IP und einem geeignetem String zusammen. Bei mir ist die IP 10.22.7.128, und daher ist der Name von meinem noten 7-128-valentin. Als geeignetes Netz habe ich 192.168.28.1/24, also Adressen von 192.168.28.2-192.168.28.255, weil die Hausnummer 28 ist :).

Hearbeat habe ich auf Anraten von einem Experten ausgemacht.

Freifunk -> Kontakt

Mindestens die Email sollte angegeben werden.

Network -> Wifi -> WIFI0

Korrekte lokale ESSID eintragen. Per default steht dort 'AP.freifunk-potsdam.de'. Mein Eintrag lautete: 'Freifunk Potsdam 7-128' wo '7' und '128' aus meiner Knoten IP stammen.

Inbetriebnahme

Aufgestellt, angeschlossen, funtzte! :)

Probleme

  • Auf der Rückseite des Gerätes befinden sich LED die Angeblich die Stärke der Verbindung anzeigen sollen, jedoch zeigen sie nichts an. Liegt vermutlich an der Firmware.
  • Die OLSR Anzeige im Webinterface unzuverlässig. Hat bisher einmal funktioniert. Es sieht so aus als müsse man das Gerät erst, dann wieder aus, und dann wieder anmachen damit die OLSR Anzeige funktioniert. Es handelt sich vermutlich um einen Bug in der Firmware, beeinträchtigt aber die Konnektivität nicht.

Offene Fragen

  • Wie funktioniert die Karte? Wann erscheint ein Knoten Dort.
  • Was sind die Möglichkeiten um eine Verbindung zu testen?
  • DNS Einstellungen